Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Post-processing & Printing | Join Upload & Sell

  

Archive 2012 · Weird CF Card Corruption
  
 
ultravista
Offline
• •
Upload & Sell: Off
p.1 #1 · Weird CF Card Corruption


I have three Lexar 300x UDMA compact flash cards. All three have been in my posession for two+ years. None have ever failed, not once.

Over the weekend, I shot approximately 450 photos with my Nikon D3.

When I tried to copy the CF to computer, I noticed two blocks of files missing, approximately 80 or so in a series.

During the copy, Windows Explorer found "duplicates" and asked if I wanted to overwrite or save a copy. I chose to save a copy. On the comptuter the file names were xxxx(2). As you may know, the same filename cannot reside in the same path; file names must be unique.

Looking at the card however, there were no "duplicates". There were however numerous folders with random ASCII characters, not were accessible however.

I ran Microsoft CheckDisc on the card and it found all sorts of errors such as "invalid time stamp", "zero file size", "file allocation is not valid", "first allocation unit is not valid" and so on.

CheckDisk recovered my missing files, all were intact and ready to go.

I doubt my D3 corrupted the card and I wonder if the card reader could be culprit.

Has anyone heard of a card reader corrupting files?

Is there any CF testing software to check performance and controller? There are a few for hard drives but I don't see anything for memory cards.

Any suggestions on what may have caused the card corruption?



Dec 04, 2012 at 04:22 AM
redcrown
Offline
• • •
Upload & Sell: Off
p.1 #2 · Weird CF Card Corruption


I've had three instances of CF card failure or corruption. In each case I rounded up the usual suspects - the card itself, the camera, the card reader, the USB cable, the xfer software, etc., and swaped out componets one at a time trying to find the culprit.

In every case, the problem ended up being the pin connections. Never the solid state memory on the card, never the USB cable, never the software.

One case was failure of the card connector (male pins) inside a Canon 5D2. Problem started intermintent, then became permanent. The 5D2 would refuse to recognize 2 of 6 CF cards I fed it. Yet other cards would work in the 5D2 and the cards the 5D2 rejected would work in other cameras.

Cost me $100 to have the 5D2 pin connector replaced by unitedcamera.com. During the transaction I had a good conversation with their repair tech. He said that 90% of CF card failures are due to connecton problems. Either bent or corroded male pins in the camera or card reader, or fouled female slots in the card itself.

Corrosion or dirty slots can often cure themselves. You stick that CF card in pocket, a dust bunny gets in there, you insert it into a camera or card reader and one or more pins are dead. You remove and re-insert a few times, and volia, the problem goes away. Ditto with corroded mail pins. After a few re-insertions, maybe the corrosion is cleared.

Why a single pin failure is not automatically detected by hardware or software is a mystery to me. I don't know what happened to parity bits or checksums from the old days, but examples are everywhere showing corrupted image data or scrambled file directories that are the result of a single bit failure somewhere in the xfer path.

Yours sounds strange in that part of the card contents were OK and part was not. But may people have reported random corruption of just a few images out of hundreds on a card. A possible, but less likely cause may be a static hit on the card. When you handle a card, it's possible that a small static charge can transfer from your hand thru the card, wiping out random bits.

So don't pet your cat on a dry, cold day and then grab your camera.



Dec 04, 2012 at 06:02 AM
JimmyStephans
Offline
• •
Upload & Sell: Off
p.1 #3 · Weird CF Card Corruption


Just last month I had an issue close to that. It turned out to be the card reader had a bent pin. Couldn't access (see in Explorer) the files but strangely the "properties" on the card showed the correct number of files and occupied space. I was getting errors saying card needed to be formatted when I knew it didn't and had just come from the camera.

Quick run to local target store for a new card reader and I was able to see the files, move them, etc. The issue was entirely the reader - which later I could see a bent pin in there.

I quickly put same card back in and took more shots. Back to the computer and new card reader and all was fine.

I feel in your case it may have been the reader not properly reading the full card and the File Allocation Table (FAT), so whatever signals it was sending Windows didn't have correct data, causing Windows to indicate corruption?



Dec 04, 2012 at 11:30 PM





FM Forums | Post-processing & Printing | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password