Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2012 · 300D died on me
  
 
Michael White
Offline
• • •
Upload & Sell: On
p.1 #1 · 300D died on me


I know it's an old camera, it was Canon's first sub 1k body. I got it back in 2004 and it has served me well. I had it out to shoot my setup shots for a shoot. It is ok, I think in program mode but the up ad right buttons as well as the set button quit responding. Isn't worth repairing if it is anything other than a software glitch. Has anyone else seen this?


Feb 06, 2012 at 07:17 AM
Gochugogi
Offline
• • • • •
Upload & Sell: Off
p.1 #2 · 300D died on me


Sure, had a few camera croak. Great excuse to try the latest and greatest. Of course, maybe you just need a PRAM reset and new backup battery (button cell).


Feb 06, 2012 at 07:48 AM
RichardLavigne
Offline
• • • • •
Upload & Sell: On
p.1 #3 · 300D died on me


I think its tie to give up the ghost and get something new... you'll be amazed by how far things have come.


Feb 06, 2012 at 01:31 PM
Mickey
Offline
• • • •
Upload & Sell: On
p.1 #4 · 300D died on me


Michael the best thing to try if you've never done so is to replace the 'button' as mentioned above. Cameras will do funny (as in BAD) things when that battery gets weak or goes dead. Certainly worth the $3 or $4 bucks to give it a try.


Feb 06, 2012 at 02:43 PM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password