Home · Register · Join Upload & Sell

  

  Previous versions of Jeff Nolten's message #15982129 « Maybe its me…but R7+Canon Adapter+EF100-400L »

  

Jeff Nolten
Offline
Upload & Sell: Off
Re: Maybe its me…but R7+Canon Adapter+EF100-400L


This is subjective but it seems that the IS on my 100-400 II wanders more and takes longer to settle on an object on my R7 than my other tele lenses including my Sigma 100-400 C. The Canon II seems steadier on my 90D. The Sig is quite steady with the R7. I don't know how this translates to subject tracking at high frame speed since I haven't done much of this yet. Funny, the Canon II will settle after a bit, maybe its training me to be steadier. I wonder if there is some interaction between the IBIS and the 100-400 II's IS? One day i should do some field testing. For now I'm sticking with the Sigma since its lighter and narrower and has been quite sharp in use.

My other EF lenses seem improved or the same. IBIS is brilliant with non-IS lenses like the 60 macro. Too bad one can't turn off IBIS without turning off the lens IS.



Jul 02, 2022 at 09:33 AM
Jeff Nolten
Offline
Upload & Sell: Off
Re: Maybe its me…but R7+Canon Adapter+EF100-400L


This is subjective but it seems that the IS on my 100-400 II wanders more and takes longer to settle on an object on my R7 than my other tele lenses including my Sigma 100-400 C. It seems steadier on my 90D. I don't know how this translates to subject tracking at high frame speed since I haven't done much of this yet. Funny, it will settle after a bit, maybe its training me to be steadier. I wonder if there is some interaction between the IBIS and the 100-400 II's IS? One day i should do some field testing. For now I'm sticking with the Sigma since its lighter and narrower hand has been quite sharp in use.

My other EF lenses seem improved or the same. IBIS is brilliant with non-IS lenses like the 60 macro. Too bad you can't turn off IBIS without turning off the lens IS.



Jul 02, 2022 at 09:20 AM





  Previous versions of Jeff Nolten's message #15982129 « Maybe its me…but R7+Canon Adapter+EF100-400L »