Finnish wearing on my 5D Mark III
/forum/topic/1154708/3

1       2       3      
4
       5       end

elader
Registered: Oct 02, 2005
Total Posts: 4583
Country: United States

I had to read all through these.... and now I'm finnished.



jcolwell
Registered: Feb 10, 2005
Total Posts: 20195
Country: Canada

Told ya!



timbop
Registered: Dec 29, 2005
Total Posts: 6307
Country: United States

mpmendenhall wrote:
The finnish is wearing off? I haiti when that happens. I czecked my 5D classic, and it's still good togo after all these years. Perhaps you should take a pole? There's norway that a sudan, widespread drop in quality would go un-noticed.

EDIT: sorry for any typos; I was russian to respond.


awesome!



acropora
Registered: Sep 22, 2011
Total Posts: 9
Country: Finland

I'm Finnish and can't really imagine wearing 5D mark III

sorry...



NYC Shooter
Registered: Dec 01, 2004
Total Posts: 14
Country: United States

OK, as requested....pics of the wear on my 5D Mark III

http://www.sendpix.com/albums/12100612/125508000000003202bc734157414773a9ce32d1efeaa/



gsmani
Registered: Mar 02, 2010
Total Posts: 864
Country: N/A

NYC Shooter wrote:
OK, as requested....pics of the wear on my 5D Mark III

http://www.sendpix.com/albums/12100612/125508000000003202bc734157414773a9ce32d1efeaa/



I dont own a 5D III so cant say if I have this problem. best is to contact canon. the finish wear is definitely unusual. other owners might comment if they are having similar issue.



PasiM
Registered: Jan 25, 2008
Total Posts: 339
Country: Finland

Well, you donīt have to use any duct tape to look like a Pr0 !



larhouser
Registered: Mar 16, 2008
Total Posts: 261
Country: United States

NO WONDER you we concerned! It looks like its been banging around the back of the pickup truck for the past 5 months!

Sorry I cant help but thanks for not editing the title of the post and letting the lads have a little fun with your typo.



jcolwell
Registered: Feb 10, 2005
Total Posts: 20195
Country: Canada

Looks like severe bag wear, to me. There's also a crease/bend and heavy scratch in the camera ID/SN plate, just ahead of the tripod mount screw. Looks to me that this camera has had very harsh treatment.



NYC Shooter
Registered: Dec 01, 2004
Total Posts: 14
Country: United States

The "Crease" is just a silver address label.



NYC Shooter
Registered: Dec 01, 2004
Total Posts: 14
Country: United States

No harsher thatn I've treated my Canon bodies since the original F1



jcolwell
Registered: Feb 10, 2005
Total Posts: 20195
Country: Canada

OK. You certainly have a serious problem. The best course is ptobably to send it in to Canon Service. If it's a production fault, you should get it fixed under warranty, or replaced.



EB-1
Registered: Jan 09, 2003
Total Posts: 22249
Country: United States

Wow, that is some wear, but it must be rubbing in the bag or case!

EBH



NYC Shooter
Registered: Dec 01, 2004
Total Posts: 14
Country: United States

I called CPS and their repsone "when you bring it in for a cleaning...point it out the service rep" Not what i was hoping to hear.



Monito
Registered: Jan 28, 2005
Total Posts: 10079
Country: Canada

NYC Shooter wrote:
OK, as requested....pics of the wear on my 5D Mark III

http://www.sendpix.com/albums/12100612/125508000000003202bc734157414773a9ce32d1efeaa/


That's severe wear.

How do you keep the camera? Does it travel mostly in a camera bag, like a LowePro? Or loose in the back trunk of a car (on carpet)? I don't expect the latter, but it looks like some kind of long term rubbing against abrasive fabric.

When that edge of the camera is touching something, what does it touch most frequently? Work gloves?

Is there any abrasive material or grit in the place the camera hangs out the most?

Does it travel for long periods of time in a vehicle?

Does it rub for long times while you walk or hike?



mttran
Registered: Nov 03, 2005
Total Posts: 6523
Country: United States

yeah, look like it has been through some sand paper treatment



AaronNegro
Registered: Apr 08, 2008
Total Posts: 1333
Country: Ireland

gsmani wrote:
NYC Shooter wrote:
OK, as requested....pics of the wear on my 5D Mark III

http://www.sendpix.com/albums/12100612/125508000000003202bc734157414773a9ce32d1efeaa/



I dont own a 5D III so cant say if I have this problem. best is to contact canon. the finish wear is definitely unusual. other owners might comment if they are having similar issue.



I have a 5DIII and mine is in pristine condition after going cycling and trekking many times, that is very odd. It is like it came from inside a Delorean.

I would contact Canon asap.




surf monkey
Registered: May 24, 2005
Total Posts: 2589
Country: United States

NYC Shooter wrote:
OK, as requested....pics of the wear on my 5D Mark III

http://www.sendpix.com/albums/12100612/125508000000003202bc734157414773a9ce32d1efeaa/


Whoa. Not what I was expecting.
Definitely not normal wear.
I'd definitely send it to Canon for them to look at.
I hope this is an isolated incident. I haven't had any issues yet.

Good luck in getting that resolved.



PetKal
Registered: Sep 06, 2007
Total Posts: 24075
Country: Canada

Reading the topic title, it sounds like it's all hell sinkin'.



EB-1
Registered: Jan 09, 2003
Total Posts: 22249
Country: United States

The irony is that through all that the title was not changed.

EBH



1       2       3      
4
       5       end