Lightroom 4.2
/forum/topic/1154198/0



sdeutscher
Registered: Feb 19, 2004
Total Posts: 146
Country: N/A

Did anyone tried the 4.2 version and can tell about the differences/improvements?



jchin
Registered: Jan 02, 2005
Total Posts: 2704
Country: United States

I just downloaded it.



JTS0719
Registered: May 13, 2009
Total Posts: 40
Country: China

sdeutscher wrote:
Did anyone tried the 4.2 version and can tell about the differences/improvements?


I find that it is slow compared to 4.1



jchin
Registered: Jan 02, 2005
Total Posts: 2704
Country: United States

For me ... it is the same as LR 4.1. Loading (starting the app) seems to take a little longer, but once it is loaded, I can move in LOOPE mode or DEVELOP mode pretty much the same as it did in LR 4.1.

Did you defrag your HD after you upgraded to LR 4.2? I just did a file-level defrag of just the "C:\Program Files" folder and it seems to be peppier today (or it could be a placebo effect).



Geofn
Registered: Jan 31, 2005
Total Posts: 842
Country: United States

I downloaded and installed it yesterday and have processed a hundred or so images. I haven't noticed any difference in speed or performance.



sdeutscher
Registered: Feb 19, 2004
Total Posts: 146
Country: N/A

For me it seems a little bit slower....but it's not much of a difference....



HawksFan66
Registered: Jan 30, 2008
Total Posts: 492
Country: United States

I find that overall 4 has been much slower than 3, but I have also noticed that 4.2 seems slower than 4.1.

Update

Just did the recommended defrag and seems to have made a huge difference.



ucphotog
Registered: May 03, 2010
Total Posts: 481
Country: United States

4.2 seems to have fixed a few bugs and added some new camera support.

https://blogs.adobe.com/lightroomjournal/2012/08/lightroom-4-2-release-candidate-now-available-on-adobe-labs.html



sdeutscher
Registered: Feb 19, 2004
Total Posts: 146
Country: N/A

Defrag doesn't work for me as I run off SSD so still a little slower



rioni
Registered: Aug 20, 2010
Total Posts: 557
Country: United States

I don't notice a difference in terms of speed.



Greggbhill
Registered: Aug 16, 2011
Total Posts: 227
Country: United States

I hadn't noticed a speed difference- I just re-applied the famous "preferences file delete" fix (link below) and it does seem a bit better. Placebo? Ymmv...

http://www.fredmiranda.com/forum/topic/1134573/1#10841107