Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

My posts · My subscriptions
  

  Previous versions of mcbroomf's message #11300111 « Metabones Speed Booster »

  

mcbroomf
Online
Upload & Sell: Off
Re: Metabones Speed Booster


I made a couple of quick/shakey measurements this morning after testing some lenses last night for the problem that prevents the shutter opening.
The lens inside the SB is ~8mm deep
The OM18 and 21/3.5 have a fin that protrudes 9mm. They are far enough in that even if my measurements are slightly off the fin would be perilously close. I'll try and do a better measurement tonight.
The OM21/2 seems to be ~8mm, but the 24/2 and 90/2 are 7mm and both fit OK.
The Pentax K 50/1.2 pin protrudes 9mm.
I'd mentioned that the 58/1.2 Rokkor wouldn't allow the shutter to open unless I wiggled it a bit (the mount to the SB is slightly loose), a 24mm VFC Rokkor that Jim converted for me, as well as a 24/1.4 FD that I bought converted and appears to have one of Jim's mounts (wide adapter) sit firmly and I can't get the shutter to open at all. I would guess that it shorting a couple of pins that the firmware doesn't like. Tonight I'll tape the pins to see if they start working. If they do perhaps Metabones could fix that with a firmware update (presumably they short the same pins on a Canon body yet don't affect it). By the way when I go into the menu it won't allow me to switch the Release W/O lens to ENABLE. I keep this option on ENABLE and when I put a lens on that's OK it defaults to that.
All of the c/y adapters/lenses I tried are OK .. I'll have to recheck the adapter I have on the 100/3.5 that seemed to black out the shutter.
35/1.4 EOS Rokinon is OK.
Tamron 90mm/2.5 52B is OK
35 FD T/S that Jim converted is OK but it has a different adapter, the width of the adapter is much thinner than the other ones so I guess it doesn't touch the pins in the SB.

Mike



Jan 26, 2013 at 10:26 AM
mcbroomf
Online
Upload & Sell: Off
Re: Metabones Speed Booster


I made a couple of quick/shakey measurements this morning after testing some lenses last night for the problem that prevents the shutter opening.
The lens inside the SB is ~8mm deep
The OM18 and 21/3.5 have a fin that protrudes 9mm. They are far enough in that even if my measurements are slightly of the fin wouldl be perilously close. I'll try and do a better measurement tonight.
The OM21/2 seems to be ~8mm, but the 24/2 and 90/2 are 7mm and both fit OK. The Pentax K 50/1.2 pin protrudes 9mm.
I'd mentioned that the 58/1.2 Rokkor wouldn't allow the shutter to open unless I wiggled it a bit (the mount to the SB is slightly loose), this also happens to a 24mm VFC Rokkor that Jim converted for me, as well as a 24/1.4 FD that I bought converted and appears to have one of Jim's mounts (wide and flat). I would guess that it shorting a couple of pins that the firmware doesn't like. Tonight I'll tape the pins to see if they start working. If they do perhaps Metabones could fix that with a firmware update (presumably they short the same pins on a Canon body yet don't affect it).
All of the c/y adapters/lenses I tried are OK .. I'll have to recheck the adapter I have on the 100/3.5 that seemed to black out the shutter.
35/1.4 EOS Rokinon is OK.
35 FD T/S that Jim converted is OK but it has a different adapter, the width of the adapter is much thinner than the other ones so I guess it doesn't touch the pins in the SB.

Mike



Jan 26, 2013 at 10:14 AM



  Previous versions of mcbroomf's message #11300111 « Metabones Speed Booster »