Home · Register · Software · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username  

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Fuji Forum | Join Upload & Sell

1
       2       end
  

Fuji EF-X500 flash experiment
  
 
photoelle
Offline
• •
Upload & Sell: On
p.1 #1 · p.1 #1 · Fuji EF-X500 flash experiment


I finally had a chance to spend some time shooting with my new Fuji EF-X500 flash, with my X-T2 and 16-55 f2.8 lens. plus the Vertical Power Boost Grip. I come from using the Canon 600EX RT and previous Canon flash systems.

The venue was indoors with very poor, ancient lighting, its really dark.

The Fuji flash is great on recycle time, fast recovery, I didn't lose any shots because it always fired.

Exposures are good, and its surprisingly powerful for its size.

Battery life was excellent. I use PowerEX rechargeables.

Shooting in TTL produced a slight delay from when the shutter button was pressed, to actual firing. I always shoot by precise timing, so the images were mostly useless. With this breed of horse, the client wants the outside front leg to be elevated, and I couldn't get that with my normal timing when the flash was in TTL.

Shooting in Manual flash was fast and accurate for my timing, and even though the horses were moving, the exposures were good, once I selected the proper output. I shoot mostly from one location, and the horses go by me.

So, I don't know if this delay in TTL can be addressed in a future firmware update, I hope so. I've never had any Canon flashes do this.

In addition, with the X-T2 I was able to shoot with ISO 2000, but with my Canon 5DM3 I had to shoot at ISO 4000. I'm very surprised at this difference.





Shot with TTL, the horse's outside front leg is not elevated.







Shot with flash set to Manual, timing is great for 3 consecutive shots.







Shot with flash set to Manual, timing is great for 3 consecutive shots.







Shot with flash set to Manual, timing is great for 3 consecutive shots.



Edited on May 29, 2017 at 11:57 PM · View previous versions



May 29, 2017 at 11:45 PM
Elisha82
Offline
• • •
Upload & Sell: Off
p.1 #2 · p.1 #2 · Fuji EF-X500 flash experiment


I don't think Fuji has a capable flash system yet. Shooting with TTL causes severe lag compared to Canon or Nikon.


May 29, 2017 at 11:50 PM
photoelle
Offline
• •
Upload & Sell: On
p.1 #3 · p.1 #3 · Fuji EF-X500 flash experiment


I had a Nissin i60a flash that was much worse. Terrible lag, and it severely affected the autofocus, making it erratic, especially in continuous mode.

So, the Fuji flash performed much better, but still, there is a small lag in TTL.



May 29, 2017 at 11:53 PM
NJPhotographer
Offline

Upload & Sell: Off
p.1 #4 · p.1 #4 · Fuji EF-X500 flash experiment


Wow, I hope they can address that. That would be too much delay for me.


Jun 01, 2017 at 12:40 AM
photoelle
Offline
• •
Upload & Sell: On
p.1 #5 · p.1 #5 · Fuji EF-X500 flash experiment


I think if your shooting does not depend on very precise timing, its workable. I'm hoping they will do an update. Otherwise, I found the flash performs well in all other ways.


Jun 01, 2017 at 01:53 PM
esanchez
Offline
• • •
Upload & Sell: On
p.1 #6 · p.1 #6 · Fuji EF-X500 flash experiment


I LOVE my Fuji but this lack of flash is frustrating me. Manual is no problem but no TTL/HSS is very disappointing.


Jun 01, 2017 at 02:03 PM
Elisha82
Offline
• • •
Upload & Sell: Off
p.1 #7 · p.1 #7 · Fuji EF-X500 flash experiment


I believe the people at Cactus mentioned that the Fuji bodies to not send/receive AF Assist information to the flash which is what probably causes the lag. Their workaround for the V6II triggers is to keep the AF Assist light on it on the whole time until the shutter is depressed.


Jun 01, 2017 at 02:52 PM
photoelle
Offline
• •
Upload & Sell: On
p.1 #8 · p.1 #8 · Fuji EF-X500 flash experiment


esanchez wrote:
I LOVE my Fuji but this lack of flash is frustrating me. Manual is no problem but no TTL/HSS is very disappointing.


The Fuji EF-X500 flash DOES have TTL and HSS with X series cameras. However, my experience was that there is a slight delay with TTL, so I changed the flash to Manual mode.



Jun 01, 2017 at 02:53 PM
esanchez
Offline
• • •
Upload & Sell: On
p.1 #9 · p.1 #9 · Fuji EF-X500 flash experiment


For what the flash cost. I would expect for it work flawless without delays.


Jun 02, 2017 at 02:25 AM
photoelle
Offline
• •
Upload & Sell: On
p.1 #10 · p.1 #10 · Fuji EF-X500 flash experiment


esanchez wrote:
For what the flash cost. I would expect for it work flawless without delays.


Yes, I agree, so I'm hoping an update can fix the issue.




Jun 02, 2017 at 02:09 PM
 

Search in Used Dept. 



James R
Offline
• • • • •
Upload & Sell: On
p.1 #11 · p.1 #11 · Fuji EF-X500 flash experiment


I rarely use TTL with Nikon, so not an issue with Fuji. But, the next generation Fuji would benefit from a more robust lighting system. And incorporate some the best ideas from Nikon and Canon systems.


Jun 08, 2017 at 08:50 PM
charles.K
Offline
• • • • •
Upload & Sell: On
p.1 #12 · p.1 #12 · Fuji EF-X500 flash experiment


I do think there is an issue with flash systems with MILC systems. I had similar issues with the A7rII with delays using TTL, where as with my D810/D750 SB910 it just works.

With my X100F I have no delays, and maybe the leaf shutter integration.

This is an issue that does need to be resolved by Fuji or some third party flashes. Once I have received the RoboSHOOT system I will test with some of my Nikon flashes and see if there are improvements.



Jun 08, 2017 at 10:13 PM
Waki
Offline
• •
Upload & Sell: Off
p.1 #13 · p.1 #13 · Fuji EF-X500 flash experiment


I just shot an event with the GFX AND x500 using TTL and didnt experience a problem. I am usually shooting manual though so thats my first work use. I use RoboShoot triggers with my Profoto lights and my SB-800/910's - no delay but those were static TTL tests.


Jun 12, 2017 at 03:42 PM
Waki
Offline
• •
Upload & Sell: Off
p.1 #14 · p.1 #14 · Fuji EF-X500 flash experiment


Actually...I was goofing with the x500, Xt2 and 400mm end of the zoom shooting hummingbirds. I was in TTL using CL and didnt have any issues. Flash mounted in the hot shoe using a MagMod flash extender thing. I have my shutter set to fire and not wait for focus. I use zone mostly, nine points. Second spot from the smallest. Could the shutter and flash be delayed due to focus and shutter settings? Just a guess....


Jun 12, 2017 at 03:48 PM
Waki
Offline
• •
Upload & Sell: Off
p.1 #15 · p.1 #15 · Fuji EF-X500 flash experiment


Ok, I grabbed my X-Pro2, the RoboShoot triggers and a round flash beauty dish along with a SB-910 flash. I hand held the flash and in TTL shot a few pics of my wife (she was not pleased) and there was absolutely no lag in flash firing - shutter and flash simultaneously. She even remarked it was so. I have release priority set to release, not focus and focus check is off. Same way I shot my Nikons for ions.
I tested firmware for John at RoboShoot for Nikon SB-800's and Profoto lights and could not recall having a lag problem but needed to make sure again. Let me know if you have questions or if I can help!
FYI, Fuji's flash systems are not real robust, I agree. The X500 is ~ok but I am waiting for Godox hopefully, to support it with a more powerful flash. I use the Godox AD200 with a manual trigger and I have no issues. I shoot Profoto B1's and D1's with an AIrRemote, no problem. Same as with my old Nikon D4s, D810, D750 and Df. Other than lack of a more powerful flash, the Fuji working with flash in studio and out, is about the same for me. I have used the Profoto TTL-N mounted on a RoboShoot MX unit and gotten excellent TTL results in testing but thats not a way I personally shoot. It does work though. The B1's in HSS work very well with the Profoto upgrade to 9 settings now. But, I have not had cause to try it yet,



Jun 12, 2017 at 04:16 PM
charles.K
Offline
• • • • •
Upload & Sell: On
p.1 #16 · p.1 #16 · Fuji EF-X500 flash experiment


Waki wrote:
Ok, I grabbed my X-Pro2, the RoboShoot triggers and a round flash beauty dish along with a SB-910 flash. I hand held the flash and in TTL shot a few pics of my wife (she was not pleased) and there was absolutely no lag in flash firing - shutter and flash simultaneously. She even remarked it was so. I have release priority set to release, not focus and focus check is off. Same way I shot my Nikons for ions.
I tested firmware for John at RoboShoot for Nikon SB-800's and Profoto lights and could not recall having a lag
...Show more

Thank you very much Wally for your in depth perspective and review. I should receive my RoboShoot triggers this week



Jun 12, 2017 at 10:10 PM
Waki
Offline
• •
Upload & Sell: Off
p.1 #17 · p.1 #17 · Fuji EF-X500 flash experiment


I hope it helps. I take Mondays off so I had time to play around with the triggers and flash. You should like the the Roboshoot products. Pricey but solid and consistent. I have five Cactus V6 triggers I cant give away. It just never worked a promised except when using a Cactus RF60 and V6II.


Jun 12, 2017 at 11:09 PM
photoelle
Offline
• •
Upload & Sell: On
p.1 #18 · p.1 #18 · Fuji EF-X500 flash experiment


Waki wrote:
Ok, I grabbed my X-Pro2, the RoboShoot triggers and a round flash beauty dish along with a SB-910 flash. I hand held the flash and in TTL shot a few pics of my wife (she was not pleased) and there was absolutely no lag in flash firing - shutter and flash simultaneously. She even remarked it was so. I have release priority set to release, not focus and focus check is off. Same way I shot my Nikons for ions.
I tested firmware for John at RoboShoot for Nikon SB-800's and Profoto lights and could not recall having a lag
...Show more

I just checked my settings and Focus Check was on, so that might be the problem. Release priority was already set to Release. Thanks for your input! I'll have to do more testing.



Jun 13, 2017 at 03:58 PM
charles.K
Offline
• • • • •
Upload & Sell: On
p.1 #19 · p.1 #19 · Fuji EF-X500 flash experiment


photoelle wrote:
I just checked my settings and Focus Check was on, so that might be the problem. Release priority was already set to Release. Thanks for your input! I'll have to do more testing.


I think Focus Check "on" is just you can fine tune the AF point manually while maintaining your AF lock with the shutter button/AF-L.



Jun 13, 2017 at 10:13 PM
rbf_
Offline
• • •
Upload & Sell: Off
p.1 #20 · p.1 #20 · Fuji EF-X500 flash experiment


charles.K wrote:
Thank you very much Wally for your in depth perspective and review. I should receive my RoboShoot triggers this week


Can't wait to hear your thoughts on the RoboShoot triggers. I've heard good things about them particularly when regarding a Nikon + Fuji kit!



Jun 13, 2017 at 11:22 PM
1
       2       end






FM Forums | Fuji Forum | Join Upload & Sell

1
       2       end
    
 

You are not logged in. Login or Register

Username     Reset password