Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2013 · normal for 5D markIII ??
  
 
winman3
Offline
• •
Upload & Sell: Off
p.1 #1 · normal for 5D markIII ??


When I attempt to review a shot(s) on the rear lcd the image is very dark as if it was underexposed by 2-3 f-stops. Of course clicking on "info" confirms a proper exposure. This happens about half the time.

Anyone else with this weirdness?

Shall I return camera for servicing?


TIA



Jun 18, 2013 at 06:48 PM
mitesh
Offline
• • • •
Upload & Sell: On
p.1 #2 · normal for 5D markIII ??


Have you checked your LCD brightness setting? Are you looking at it in bright or direct sunlight? I have not noticed this with mine.


Jun 18, 2013 at 06:53 PM
John_T
Offline
• • • •
Upload & Sell: On
p.1 #3 · normal for 5D markIII ??


There is also an ambient light sensor between the trashcan button and the Canon logo beneath the LCD screen that you may be covering and uncovering with your thumb if screen brightness is set to Auto.

Alternatively you are hitting the DOF simulation button in the grip to the right of the lens mount.



Jun 18, 2013 at 07:11 PM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password