Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Nikon Forum | Join Upload & Sell

  

Archive 2013 · Bizarre issue with my D600
  
 
Kroot
Offline

Upload & Sell: Off
p.1 #1 · Bizarre issue with my D600


I pulled my D600 out of my bag today to show off my new Rokinon 14mm lens to a friend and when I put it up to my eye I noticed that the viewfinder is all out of whack. It is blurry, dark and does not display any focus points/gridlines. When I hold down my AF button, the edges of the screen glow red but no focus points are illuminated. The camera will shift the lens around and claim to be in focus, but the image through the viewfinder is still very blurred. When I take a picture it comes out about 2 stops over-exposed, though it does appear to be in good focus.

It gets weirder: when I put the camera in live-view mode, everything works perfectly. The exposure and focus are spot-on.


I looked around in the mirrorbox area, but can't see anything obviously wrong with the mechanisms. Googling around I can't really tell if this has happened to anyone else before. The camera worked perfectly for me last night, and I did nothing inbetween besides formatting some memory cards, charging the battery and putting it in my bag. Anyone out there have any idea what might be going on? I suspect I'm going to have to send it in for warranty repair, but I'm holding onto slim hope that there's a quick and easy fix available.



Jun 13, 2013 at 11:46 PM
BenV
Offline
• • • • •
Upload & Sell: On
p.1 #2 · Bizarre issue with my D600


turn the little knob on the eye piece, its tiny.


Jun 14, 2013 at 12:26 AM
Kroot
Offline

Upload & Sell: Off
p.1 #3 · Bizarre issue with my D600


It's definitely not the diopter adjustment. That wouldn't cause the viewfinder to be darker than normal or "break" the focus point/gridline display.


Jun 14, 2013 at 12:29 AM
jasoncallen
Offline
• • • •
Upload & Sell: Off
p.1 #4 · Bizarre issue with my D600


Sounds primarily like a mirror box issue - that I've had previously on other systems (Canon) - where the mirror is not returning to the "resting" position... It's dimmer because less light is getting reflected into the prism, and the image is blurry because the mirror is at the incorrect distance to the prism. Have you tried cycling the mirror/shutter with the lens detached to see if the mirror is returning properly? The over exposure may be due to a shutter issue. It almost seems like there's some kind of obstruction in your mirror box.


Jun 14, 2013 at 12:45 AM
pburke
Offline
• • •
Upload & Sell: Off
p.1 #5 · Bizarre issue with my D600


when I got my D600 I put a lens on it before even inserting the battery - the viewfinder was blurry and obviously no grid lines. I could not focus any lens (such as my Rokinon 85mm). Once I put the battery in, even at power off, the viewfinder cleared up. Maybe there's a power issue with your viewfinder? It will go blurry without power - obviously if it is that, that's bad news for you, because clearly you have power in the camera if you can do live view and take photos while the viewfinder is fuzzy.





Jun 14, 2013 at 12:51 AM
Mescalamba
Offline
• • • •
Upload & Sell: Off
p.1 #6 · Bizarre issue with my D600


Nikon OVFs need to be "powered" by battery. If they are not, exactly what you are describing will happen.

If someone doesnt believe me, remove battery from your camera and look through OVF.

My guess is that wiring went off probably, or whatever powers that thing up. Either way its case for service.

Edit: Seems someone else was faster writer than me. As pburke said.



Jun 14, 2013 at 12:54 AM
 

Search in Used Dept. 



Kroot
Offline

Upload & Sell: Off
p.1 #7 · Bizarre issue with my D600


Well, that sucks. Luckily it's still under warranty. I guess I'll get the paperwork started on a support claim.


Jun 14, 2013 at 01:39 AM
jasoncallen
Offline
• • • •
Upload & Sell: Off
p.1 #8 · Bizarre issue with my D600


Weird - I'd never seen that before! I just removed my D700's battery after reading this, and sure enough, BAM, same thing! Cool insight, pburke. Might be a faster fix than a mechanical issue with the mirror and shutter.

pburke wrote:
when I got my D600 I put a lens on it before even inserting the battery - the viewfinder was blurry and obviously no grid lines. I could not focus any lens (such as my Rokinon 85mm). Once I put the battery in, even at power off, the viewfinder cleared up. Maybe there's a power issue with your viewfinder? It will go blurry without power - obviously if it is that, that's bad news for you, because clearly you have power in the camera if you can do live view and take photos while the viewfinder is fuzzy.





Jun 14, 2013 at 01:41 AM
Frank_Maiello
Offline
• •
Upload & Sell: Off
p.1 #9 · Bizarre issue with my D600


Apparently, the LCD overlay needs power to make itself transparent.


Jun 14, 2013 at 12:46 PM
tach18k
Offline
• • •
Upload & Sell: Off
p.1 #10 · Bizarre issue with my D600


Make sure your battery is full charged. also make sure your charger is working, there is another issue here that a D600 drained its battery.


Jun 14, 2013 at 09:54 PM
Kroot
Offline

Upload & Sell: Off
p.1 #11 · Bizarre issue with my D600


Battery was working fine, I even tried a different battery to be sure. Sent the camera in for warranty, so I guess I'm just sitting on my hands for a couple weeks. C'est la vie.


Jun 16, 2013 at 05:51 PM





FM Forums | Nikon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password