Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Lighting & Studio Techniques | Join Upload & Sell

  

Archive 2013 · Speedlite not flashing
  
 
mclldavidson
Online
• •
Upload & Sell: On
p.1 #1 · Speedlite not flashing


I have a 430 ex and just the past couple days it stopped working. The red light is solid and a green light below it occasionally comes on. Also on the front there is a solid red light

Edited on May 21, 2013 at 10:26 PM · View previous versions



May 21, 2013 at 09:56 PM
jefferies1
Offline
• • • •
Upload & Sell: Off
p.1 #2 · Speedlite not flashing


Could be a flash tube. I have burned out several using 580 models but never used the 430.Repaired 2 this year. At United Camera the fix runs about $85.00 from what they list. Think Canon is closer to $150.00 if my memory is correct.
( they actually sent one to Canon for repair. Called to tell me it would be a delay, the other 2 times it appeared to be done in house as it was faster)

Try new batteries, clean the contacts, make sure the battery door is closing tight. If none of the above then most likely the flash tube.

If it is only an on camera issue check the hot shoe. If The screws came loose the flash may not fire at all and sometimes work then be way too bright or dim.



May 21, 2013 at 10:22 PM
BrianO
Offline
• • • • •
Upload & Sell: On
p.1 #3 · Speedlite not flashing


mclldavidson wrote:
...on the front there is a solid red light


Uh oh.

The red light on the front should flash when the 430EX is in Slave mode, and it should be off when mounted on the camera. It could also be the AF Assist Beam emitter, which should only be on when the shutter button is half-pressed. If it's on constantly, then I think you have a logic error or an internal short.

If taking out and then replacing the batteries doesn't fix it, I think it's a repair/replace situation.



May 22, 2013 at 05:32 AM
Michael White
Offline
• • •
Upload & Sell: On
p.1 #4 · Speedlite not flashing


Also verify cf settings as well as the mode, channel and other settings. Best to rest to factory default on camera with new batteries and goe from there but sound like maybe a bad flash tube.


May 22, 2013 at 06:18 AM
 

Search in Used Dept. 



mclldavidson
Online
• •
Upload & Sell: On
p.1 #5 · Speedlite not flashing


Ok I took it off and removed the batteries and it will fire off the camera. I then put it on my camera and it works but that red light on the front it still there


May 22, 2013 at 07:46 PM
BrianO
Offline
• • • • •
Upload & Sell: On
p.1 #6 · Speedlite not flashing


mclldavidson wrote:
Ok I took it off and removed the batteries and it will fire off the camera. I then put it on my camera and it works but that red light on the front it still there


If you have another camera, or a friend with one, I'd see what it does on a different body; it could be a camera problem (shutter release button) if it's not a flash problem.



May 22, 2013 at 07:49 PM
mclldavidson
Online
• •
Upload & Sell: On
p.1 #7 · Speedlite not flashing


I dont have a different camera but it stays on even when off the camera


May 22, 2013 at 07:51 PM
BrianO
Offline
• • • • •
Upload & Sell: On
p.1 #8 · Speedlite not flashing


mclldavidson wrote:
I dont have a different camera but it stays on even when off the camera


Ah, gotcha.



May 22, 2013 at 10:59 PM





FM Forums | Lighting & Studio Techniques | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password