Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2013 · Dead Rebel XTi
  
 
D Strass
Offline
• •
Upload & Sell: On
p.1 #1 · p.1 #1 · Dead Rebel XTi


A friend of mine has a Canon Rebel XTi, and it died. He says the battery is charged, and it hasn't gotten wet at all. It worked the other morning, then 2 hours later- nothing. No error code, no blinkies, just nothing.

Any ideas? Anyone else had this problem?



Jan 07, 2013 at 01:56 PM
Alex de Groot
Offline

Upload & Sell: Off
p.1 #2 · p.1 #2 · Dead Rebel XTi


All I can say is I had something simelar I thought my camera (550d, is that XTi?) was dead, but it was the sd card slot cover that wasn't closed properly, the the camera did nothing at all, nothing on the display even I think. Closed the cover and everything was fine again.


Jan 07, 2013 at 02:06 PM
Ian.Dobinson
Offline
• • • • • •
Upload & Sell: Off
p.1 #3 · p.1 #3 · Dead Rebel XTi


Yep check the card cover

By the way the XTi is the 400D . The last rebel to take CF cards



Jan 07, 2013 at 02:44 PM
AmIgone
Offline
• •
Upload & Sell: Off
p.1 #4 · p.1 #4 · Dead Rebel XTi


I would try a known good battery. I had one go bad for my 5D after using it. I used it and then recharged it but nothing happened when I put it in the camera. It seemed to charge fine, the light blinked like it was supposed to, and then went solid. When I got around to using it again, nothing, notta, zip. I thought my camera was dead. I put another one in and it was fine. Put the bad one back in and nothing. So I put the bad one back on the charger and it blinked for a few seconds and went to a solid charged light but when you put it in the camera, nothing.


Jan 07, 2013 at 04:20 PM
 

Search in Used Dept. 



Gochugogi
Offline
• • • • •
Upload & Sell: Off
p.1 #5 · p.1 #5 · Dead Rebel XTi


I have fond memories of the XTi, having taken one to Europe in 2008. Is your friend using the original battery? The Xti dates from 2007. A five or six year old battery is bound to croak as normal life is 2-3 years. I've had batteries barely last one year.


Jan 07, 2013 at 04:54 PM
D Strass
Offline
• •
Upload & Sell: On
p.1 #6 · p.1 #6 · Dead Rebel XTi


Thanks everyone, I'll have him check some of these things.


Jan 07, 2013 at 05:53 PM
AmbientMike
Offline
• • •
Upload & Sell: Off
p.1 #7 · p.1 #7 · Dead Rebel XTi


Battery door and card slot door have a little pin that turns off the camera if the door is open. If that broke would be a problem.


Jan 07, 2013 at 07:18 PM
wlderdude
Offline
• •
Upload & Sell: Off
p.1 #8 · p.1 #8 · Dead Rebel XTi


If there is any reason to suspect the battery, they can be had on ebay really cheap. My XTi went out on me a year ago, and a new $5 battery was all it took to get it going again. It still takes several hundred shot between charges.


Jan 08, 2013 at 11:09 PM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password