Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Alternative Gear & Lenses | Join Upload & Sell

  

Archive 2012 · Problem with Sigma Lens
  
 
Tim Feeney
Offline

Upload & Sell: Off
p.1 #1 · p.1 #1 · Problem with Sigma Lens


I have a Sigma 12-24 AT-X pro f/4 lens is giving me trouble, and I'm stumped. Earlier this fall, the lens was giving me communication errors, but only at certain focal lengths. For instance, it would work fine between about 18mm-24mm, but would give me a "lens communication error" between 12mm-18mm.

I limped along with it like that until a couple weeks ago, when I put it on, and it wouldn't work at any focal length whatsoever. Having no immediate funds for repair, I set it aside until today, when a friend called and asked if I could sub for him on a real estate shoot in the next couple of days. I declined due to the lens issue, but then decided to put it back on and see what happened. Suddenly, the lens is working fine, at all apertures, for no reason whatsoever!

Obviously this is a bittersweet occurrence, because I'm not confident that it will continue to work, and I don't want to look like a jackass by showing up with malfunctioning gear. I also have a tokina fisheye lens that might work in a pinch, but that's a last resort.

I'm just wondering if anyone has ever encountered similar problems, and if so, thoughts on potential causes/fixes. btw, I forgot to mention that I shoot with a Canon T1i, hopefully soon to be upgrading to the T3i, or a used 5d mark II.




Nov 07, 2012 at 02:03 AM
ZoneV
Offline
• • •
Upload & Sell: Off
p.1 #2 · p.1 #2 · Problem with Sigma Lens


Tokina or Sigma lens?
Sounds like Tokina 12-24 AT-X pro.
There it is a common lens defect that the flex cable breaks:

http://www.youtube.com/watch?v=evYdAdsFZy4
http://forum.photozone.de/index.php?/topic/1156-designproduction-error-tokina-at-x-pro-12-24mm-f4-dx/

Two pictures of DIY repair:
http://www.flickr.com/photos/clonet/sets/72157631307233214/with/7888382236/



Nov 14, 2012 at 10:49 PM
AmbientMike
Offline
• • •
Upload & Sell: Off
p.1 #3 · p.1 #3 · Problem with Sigma Lens


Had similar issue with Tamron 75-300. One day quit working past 200, but it wasn't that good past 200. I,ll have to check out links. Should work wide open. Might have to tape it. I might stop it down to f 8 with stop down, pull it off and tape contacts. Should stay at f 8. No idea if this hurts lens done it w/11-16.


Nov 15, 2012 at 03:12 AM
cputeq
Online
• • • •
Upload & Sell: On
p.1 #4 · p.1 #4 · Problem with Sigma Lens


Sounds like an intermittent open somewhere in the wires or a solder joint.



Nov 15, 2012 at 04:16 AM





FM Forums | Alternative Gear & Lenses | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Reset password