Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2012 · Unreliable AF on 7D with FW 2.0.3?
  
 
Scratchen
Offline

Upload & Sell: Off
p.1 #1 · Unreliable AF on 7D with FW 2.0.3?


Hi all,

Before I bought the 7D, I had a 50D, and all my lenses focused perfectly with that camera body.

I recently updated the firmware on my 7D to 2.0.3. Was running 2.0 before (with no obvious issues).
Right away after updating I noticed that the AF had become very unreliable. It had a hard time locking and was hunting way more than before.

Especially with my f/1.4 lenses, a Sigma 85/1.4 and Canon 50/1.4, the AF is way off. The camera indicates that focus has been locked, but when I view the picture it is often very front focused. Sometimes though (about 10-20% of the time), the focus is spot on as it should be.
I also have a Canon 100/2.8 USM Macro and a Sigma 17-50/2.8 OS that show the same behaviour.

Actually, my only lenses that focus as they should right now are my Sigma 120-300/2.8 OS and Tokina 11-16/2.8.

I've tried using all the different AF-options, but nothing seems to help. I've reset the camera settings, done a hard reset, cleaned all connections between body and lenses.. Nothing has helped. It really seems like FW 2.0.3 is the bad guy here.

Has anyone else noticed this? It's driving me insane at the moment..

This exact thread has also been posten on canonrumors.com, and there are quite a few experiencing the same issues Im afraid..



Oct 15, 2012 at 10:34 PM
AGeoJO
Offline
• • • • • •
Upload & Sell: On
p.1 #2 · Unreliable AF on 7D with FW 2.0.3?


I did not encounter that issue with mine and I have not seen any other report of that issue but I am not discrediting your case. I would suggest contacting Canon in your country to find out whether they could help you with that issue. I would reinstall the firmware in the camera and find out whether the problem persists - just shooting in the dark here.


Oct 15, 2012 at 11:55 PM
Pixel Perfect
Offline
• • • • • •
Upload & Sell: On
p.1 #3 · Unreliable AF on 7D with FW 2.0.3?


Scratchen wrote:
Hi all,

Before I bought the 7D, I had a 50D, and all my lenses focused perfectly with that camera body.

I recently updated the firmware on my 7D to 2.0.3. Was running 2.0 before (with no obvious issues).
Right away after updating I noticed that the AF had become very unreliable. It had a hard time locking and was hunting way more than before.

Especially with my f/1.4 lenses, a Sigma 85/1.4 and Canon 50/1.4, the AF is way off. The camera indicates that focus has been locked, but when I view the picture it is often very front focused. Sometimes though
...Show more

Have you checked your CFn settings since updating as they may have been reset?



Oct 15, 2012 at 11:57 PM
Liquidstone
Offline
• • •
Upload & Sell: Off
p.1 #4 · Unreliable AF on 7D with FW 2.0.3?


No AF issue on mine, before and after FW 2.0.3


Oct 16, 2012 at 01:21 AM
sritri
Offline
• • • •
Upload & Sell: On
p.1 #5 · Unreliable AF on 7D with FW 2.0.3?


I had an issue with the firmware itself behaving erratically but after a third try all is well. I have posted the issues I faced here, but none with AF


Oct 16, 2012 at 03:30 AM
mco_970
Offline
• • • • •
Upload & Sell: On
p.1 #6 · Unreliable AF on 7D with FW 2.0.3?


Definitely try pulling out both the regular battery and the clock battery, switch the camera on and let it sit for a while (15 minutes or overnight if you want to be SURE the reset takes). Maybe a hard reset will clear out the ghosts in the machine.


Oct 16, 2012 at 03:38 AM
Scratchen
Offline

Upload & Sell: Off
p.1 #7 · Unreliable AF on 7D with FW 2.0.3?


AGeoJO wrote:
I did not encounter that issue with mine and I have not seen any other report of that issue but I am not discrediting your case. I would suggest contacting Canon in your country to find out whether they could help you with that issue. I would reinstall the firmware in the camera and find out whether the problem persists - just shooting in the dark here.

I've reinstalled the firmware twice, following the update instructions to the point. I've been in contact with Canon, and will probably send my 7D to them to check it out since Im still under warranty.



Oct 16, 2012 at 08:15 AM
 

Search in Used Dept. 



Scratchen
Offline

Upload & Sell: Off
p.1 #8 · Unreliable AF on 7D with FW 2.0.3?


mco_970 wrote:
Definitely try pulling out both the regular battery and the clock battery, switch the camera on and let it sit for a while (15 minutes or overnight if you want to be SURE the reset takes). Maybe a hard reset will clear out the ghosts in the machine.

Done that. Had mine completely dark for 12h (removed both batteries, LP-E6 and the clock battery).



Oct 16, 2012 at 08:16 AM
Gochugogi
Offline
• • • • •
Upload & Sell: Off
p.1 #9 · Unreliable AF on 7D with FW 2.0.3?


Mine has worked perfectly with both FW2.0 and 2.0.3. Not any better than the prior FW1.x. I wish the FW reorganized the AF modes so you can override auto AF select by simply moving the joystick rather than having individual pt selection in a separate mode.


Oct 16, 2012 at 08:24 AM
shroud72
Offline

Upload & Sell: Off
p.1 #10 · Unreliable AF on 7D with FW 2.0.3?


Just wondering how you like your 7d with Sigma 120-300/2.8 OS as I was considering this setup instead of the Canon EF 100-400 lens. Do you find the Sigma 120-300/2.8 OS is able to be handheld without the need for a tripod? Have you tried the Sigma 120-300/2.8 OS with 1.4x and 2x teleconverter?


Oct 16, 2012 at 12:13 PM
Scratchen
Offline

Upload & Sell: Off
p.1 #11 · Unreliable AF on 7D with FW 2.0.3?


shroud72 wrote:
Just wondering how you like your 7d with Sigma 120-300/2.8 OS as I was considering this setup instead of the Canon EF 100-400 lens. Do you find the Sigma 120-300/2.8 OS is able to be handheld without the need for a tripod? Have you tried the Sigma 120-300/2.8 OS with 1.4x and 2x teleconverter?

I'm extremely happy with my 120-300/2.8 OS! It's very very sharp even wide open, and goes well with both the 1.4x and 2x (I own the DG-versions). OS seems to be a tad less effective than on my previous lens, Canon 300/4 L IS, though, but still works great.



Oct 16, 2012 at 01:31 PM
gschlact
Offline
• • •
Upload & Sell: On
p.1 #12 · Unreliable AF on 7D with FW 2.0.3?


Are you using single shot or AI Servo mode?


Oct 16, 2012 at 10:13 PM
Lance Couture
Offline
• • • •
Upload & Sell: On
p.1 #13 · Unreliable AF on 7D with FW 2.0.3?


Liquidstone wrote:
No AF issue on mine, before and after FW 2.0.3


Same for me.



Oct 18, 2012 at 08:18 AM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password