Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Alternative Gear & Lenses | Join Upload & Sell

  

Archive 2012 · Zeiss CPU connector defect
  
 
kinetic
Offline
• • •
Upload & Sell: Off
p.1 #1 · p.1 #1 · Zeiss CPU connector defect


Looks like my new Zeiss Distagon T* 2,8/21 ZF.2 has a defect in the CPU connector. Last night I was shooting and all of a sudden my LED screen on my D800e showed delta F6. Apparently it lost the CPU connection. I tried my other lenses and they were all fine. Once in awhile the connection between lens and camera come back on, but it's not good for a new lens.

I'm pretty sure the depressed connector is the issue.

Have you guys ever seen this?
Should I send it in to Zeiss for warranty repair?
Should I just return it and grab another copy?
If this is normal for the connector, what else could be wrong?




Aug 03, 2012 at 08:50 PM
phuang3
Offline
• • •
Upload & Sell: Off
p.1 #2 · p.1 #2 · Zeiss CPU connector defect


This happened on my digital rebel before. I had to dissemble the camera and pushed the pin out. I'd suggest applying some light grease on each of the contacts.


Aug 03, 2012 at 10:57 PM
kinetic
Offline
• • •
Upload & Sell: Off
p.1 #3 · p.1 #3 · Zeiss CPU connector defect


This isn't the camera...


Aug 04, 2012 at 01:41 AM
 

Search in Used Dept. 



Gary Clennan
Offline
• • • • •
Upload & Sell: On
p.1 #4 · p.1 #4 · Zeiss CPU connector defect


I have never seen this or experienced it on any of my Zeiss lenses. I would just return it for another.


Aug 04, 2012 at 03:19 AM
MarkJones
Offline
• •
Upload & Sell: Off
p.1 #5 · p.1 #5 · Zeiss CPU connector defect


Try running your finger nail over the offending contact a few times pushing it in and releasing it suddenly, there may be some dust or something preventing it from poping out. On the other hand if that doesn't work return it!


Aug 04, 2012 at 02:49 PM
Lan11
Offline
• •
Upload & Sell: Off
p.1 #6 · p.1 #6 · Zeiss CPU connector defect


That's Cosina quality. I wonder if ZF lenses show underexposure.
All my ZE lenses were underexposing at least 1 stop.



Aug 04, 2012 at 03:17 PM





FM Forums | Alternative Gear & Lenses | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Reset password