Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2012 · 7D & Tokina 12-24 wiggly
  
 
jalamiller
Offline

Upload & Sell: Off
p.1 #1 · p.1 #1 · 7D & Tokina 12-24 wiggly


Anyone had any issues shooting with the Tokina 12-24mm on a 7D? I've used the Tokina for years without issue on the following: 10D, 30D, Rebel XTi. Since I've purchased my 7D, the lens gives me errors sometimes. The camera tells me it and the lens are not communicating.It is a contact issue, especially when I'm vertical. If I wiggle the lens around, or press if firmly to the body, it will work.

Anyone know, can I get this fixed? It appears all the mounts are tight as they should be on each item. It seems more a problem with the machining of the two items that they just don't fit tight.

Any thoughts?



Feb 21, 2012 at 02:55 AM
msalvetti
Offline
• • • •
Upload & Sell: On
p.1 #2 · p.1 #2 · 7D & Tokina 12-24 wiggly


I don't get errors, but I also don't get very good focus with mine. Especially in low light. Worked fine on my 40D, but the 7D seems to be a different story.

I don't use the 12-24 much, and I haven't spent a lot of time trying to figure this out.

Mark



Feb 21, 2012 at 03:56 AM
beppephoto
Offline

Upload & Sell: Off
p.1 #3 · p.1 #3 · 7D & Tokina 12-24 wiggly


I had some problems with this combo, but it was a lens issue.
I was able to use it only wide open, at f4, it was impossible to shoot at different aperture due to the contact issue error.
It was a lens electrical problem, but it has been succesfully fixed.

Bye



Feb 21, 2012 at 08:52 AM
harland
Offline
• • •
Upload & Sell: On
p.1 #4 · p.1 #4 · 7D & Tokina 12-24 wiggly


I had that error message recently when using this lens on my 40D. I had to send the lens in to Tokina for repair ($120)


Feb 22, 2012 at 11:12 AM
jalamiller
Offline

Upload & Sell: Off
p.1 #5 · p.1 #5 · 7D & Tokina 12-24 wiggly


Thanks all. It appears that it is an issue with the Tokina lens and either the mount or some of the electronic connections. This is sort of what I figured. Thanks.


Feb 22, 2012 at 08:13 PM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password