Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2012 · 580EX flash won't fire - help!
  
 
jfwoodman
Offline
• • • •
Upload & Sell: On
p.1 #1 · p.1 #1 · 580EX flash won't fire - help!


I'm near the end of my birding trip to Panama, and my 580EX flash simply stopped firing after fairly light use. Pilot light stays red indefinitely. There is the brief normal whine when switched on, but it abruptly changes to an intermittent soft pulse (a very soft beep) as it seems to fail to charge.

Yes, fresh batteries have been triple checked. Contacts are clean.

Anyone run across this and find a fix? Sending to Canon doesn't help me now, and no opportunity to pick up new one where I am.

Thanks

Jim



Feb 20, 2012 at 11:54 PM
timbop
Offline
• • • • •
Upload & Sell: On
p.1 #2 · p.1 #2 · 580EX flash won't fire - help!


try taking it out of ettl and putting it in manual. It's pretty humid there, is it possible it's just a moisture issue?


Feb 21, 2012 at 12:29 AM
JimboCin
Offline
• • •
Upload & Sell: Off
p.1 #3 · p.1 #3 · 580EX flash won't fire - help!


The sounds you hear are totally normal for the 580EX.

Does the flash fire if you press the red "Pilot" light/button?



Feb 21, 2012 at 12:59 AM
 

Search in Used Dept. 



bbasiaga
Offline
• • •
Upload & Sell: Off
p.1 #4 · p.1 #4 · 580EX flash won't fire - help!


Also check that you did nt accidentally set it to not fire either in the flash menus itself or the camera's menues. i have done that to myself once (maybe twice )

=Brian



Feb 21, 2012 at 02:20 AM
DmitriM
Offline
• • •
Upload & Sell: Off
p.1 #5 · p.1 #5 · 580EX flash won't fire - help!


jfwoodman wrote:
I'm near the end of my birding trip to Panama, and my 580EX flash simply stopped firing after fairly light use. Pilot light stays red indefinitely. There is the brief normal whine when switched on, but it abruptly changes to an intermittent soft pulse (a very soft beep) as it seems to fail to charge.

Yes, fresh batteries have been triple checked. Contacts are clean.

Anyone run across this and find a fix? Sending to Canon doesn't help me now, and no opportunity to pick up new one where I am.

Thanks

Jim


Jim, the bulb is burned out and needs to be replaced. It will cost you around $70-130 with parts and labor. There's no way around it.



Feb 21, 2012 at 02:34 AM
jfwoodman
Offline
• • • •
Upload & Sell: On
p.1 #6 · p.1 #6 · 580EX flash won't fire - help!


Thanks all! Perhaps it was a humidity thing (makes sense). But after several hours back at the lodge, I switched from ettl to M and it fired. Then switched back to ettl and it fired. I'm pretty sure I toggled that in the field to no effect, but perhaps not. So I'm not sure if the switch or some time indoors cured it, but it works for now.

I still find it odd that the red pilot light does not switch off anymore after it powers up (pilot going off after a few moments is normal, right?). But we'll see what happens in the field maņana. Thanks again, all, for the quick advice.



Feb 21, 2012 at 02:46 AM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Reset password