Home · Register · Software · Software · Join Upload & Sell

Moderated by: Fred Miranda

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist

FM Forums | Canon Forum | Join Upload & Sell


Archive 2012 · Shutter Problem or something else? Canon 40D
• •
Upload & Sell: Off
p.1 #1 · p.1 #1 · Shutter Problem or something else? Canon 40D

Since about December, my 40D has been having poor response when I try to take photos. I first noticed this when taking Christmas card pictures with a 580 EX II mounted. I would press the button and no shutter release. After a couple of presses it might take a photo. I first thought it was due to a focus or metering problem, but itís getting worse. Today I was trying to take pictures in full daylight, manual settings and manual focus. It would not release the shutter, then when it was inside and pointing at the ceiling Ė I gave it one more try and it took the shot.

Iím pretty certain I need to send this to Canon for repair, I had the shutter replaced about a year ago. Does anyone have thoughts as to what is damaged (shutter or something else) or what I might try to fix it? I once had a computer that wouldnít power up and it ended up being dust in the bezel. If there are any similar quick fixes I could try Iíll appreciate hearing them.

Thank You,

Feb 05, 2012 at 02:06 AM
• • • •
Upload & Sell: Off
p.1 #2 · p.1 #2 · Shutter Problem or something else? Canon 40D

If you are in one shot mode, the camera must AF before it will actuate the shutter. That is unlikely to happen pointing it at a white featureless ceiling.

Put the camera on the full automatic green box mode. If it works fine, you have narrowed it down to a focus issue, then try a different lens to see if its lens or body.


Feb 05, 2012 at 02:23 AM
• • • •
Upload & Sell: On
p.1 #3 · p.1 #3 · Shutter Problem or something else? Canon 40D

could be a faulty shutter button also. Do you have a grip on it that you can see if that button is any better?

Feb 05, 2012 at 02:26 AM
• • • • •
Upload & Sell: Off
p.1 #4 · p.1 #4 · Shutter Problem or something else? Canon 40D

Another possibility is a gummed-up shutter release button.

If you have the cable and software needed for tethered shooting you can try to shoot using the computer rather than the shutter release button; or you can use a shutter-release cable if you have one.

If it works using alternate release methods, you'll have narrowed it down to a problem with the button.

[Edit] I need to learn to type faster. JohnBrose beat me to it.

If it is the shutter release, brave souls have used the following to fix it themselves:

As you can see below, it's not an uncommon issue:


Feb 05, 2012 at 02:29 AM
• •
Upload & Sell: Off
p.1 #5 · p.1 #5 · Shutter Problem or something else? Canon 40D

Thanks All!

scalesusa - Yes, I was in Single Shot mode if I follow you. I don't quite follow the thought process if I'm shooting in Manual with Manual Focus, but I put it in Green (I hope nobody saw me ) and put the lens back into auto focus... Shots 6 and 22 fired,the other 20 were blanks - I was pointing at various targets and had a variety AF points highlight. I even had the onboard flash pop up and toss out some preflash feelers (I forget what that's called). Thank You for the suggestion!

JohnBrose & BrianO - Great Suggestions, I'm off to try them!....

....You Rock!! I use a remote release and it snapped every time! Went back to the shutter button and it worked consistently for a while, then stopped again. Put the remote back on and both worked again. I'm not certain what to do now!

I'll test it throughout the night, then again tomorrow. If the shutter button locks up again, I may have a couple Guinness and give the Isopropyl a try. If I have to send it in anyway... Thanks for the Tips and the Youtube link

Just tried it again before posting - button is working 'most' of the time... Better make sure I have some Guinness.


Feb 05, 2012 at 05:29 AM

FM Forums | Canon Forum | Join Upload & Sell


You are not logged in. Login or Register

Username     Reset password