Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

  

Archive 2011 · Used 5D MK II won't focus except in P mode
  
 
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #1 · Used 5D MK II won't focus except in P mode


Just bought a used 5d Mk II off these forums.

It has 2 problems. It won't focus with the 1/2 shutter push except in [ ] (green, full auto) mode. In all other modes, it ignores the 1/2 shutter press. It's not a matter of lens or lighting because if I press the AF button it will instantaneously auto-focus and it happens on more than one lens.

I've tried resetting to factory to factory defaults with no change in behavior. Firmware rev is 2.07.

The other issue is that it's consistently underexposing by a stop when I use it with my 580EX flash. If I move the flash over to my rebel Xsi the exposure is perfect.

Please tell me this is user error of some type. Otherwise, I'm pretty distraught!

Edited on Dec 09, 2011 at 11:28 PM · View previous versions



Dec 09, 2011 at 11:24 PM
Rob Whiting
Offline
• •
Upload & Sell: Off
p.1 #2 · Used 5D MK II won't focus except in P mode


Is your custom function set for back button focus? probably is...

check your manual (I don't have one handy). If the "AF ON" button works for focusing in other modes, that's likely the problem.

edit:

here it is:
Custom Function Group IV Operation/Others settings

C.Fn IV -1 Shutter button/AF-ON button

This is one of the most used Custom Functions as it allows you to set back button focus, so you can shoot static and moving subjects without having to change the AF mode.

Setting 0 by default the Shutter button and AF-ON button both activate metering and start AF functions.
Setting 1 causes the shutter button to start metering and AF operation, while the AF-ON button acts as an AF Stop to pause AF operation.
Setting 2 this is one of the most common choices. The shutter button will start exposure metering and the AF-ON button will start autofocus and metering.
Setting 3 this is another common one, with the shutter button being used to activate AE lock and the AF-ON button starting metering and autofocus.
Setting 4 this disables the AF-ON button and makes the shutter button start both metering and autofocus.

make sure C.Fn IV -1 is set to 0 if you want 1/2 shutter button press to start auto focus

Edited on Dec 09, 2011 at 11:31 PM · View previous versions



Dec 09, 2011 at 11:27 PM
gvg45
Offline
• • •
Upload & Sell: Off
p.1 #3 · Used 5D MK II won't focus except in P mode


I know you mentioned you reset factory defaults, but the focusing issue seems like C.Fn 4-1 is set to something other than 0.


Dec 09, 2011 at 11:30 PM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #4 · Used 5D MK II won't focus except in P mode


Rob Whiting wrote:
Is your custom function set for back button focus? probably is...

check your manual (I don't have one handy). If the "AF ON" button works for focusing in other modes, that's likely the problem.


wouldn't that get cleared when I reset to factory defaults?



Dec 09, 2011 at 11:30 PM
Rob Whiting
Offline
• •
Upload & Sell: Off
p.1 #5 · Used 5D MK II won't focus except in P mode


jzucker wrote:


wouldn't that get cleared when I reset to factory defaults?


I would think so.. you'll have to check.. is C.Fn IV -1 set to 0?


Edited on Dec 09, 2011 at 11:33 PM · View previous versions



Dec 09, 2011 at 11:33 PM
Rob Whiting
Offline
• •
Upload & Sell: Off
p.1 #6 · Used 5D MK II won't focus except in P mode






Dec 09, 2011 at 11:33 PM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #7 · Used 5D MK II won't focus except in P mode


I just cleared custom functions and it started working again in all modes with the 1/2 press. Shouldn't the factory settings reset clear that?




Dec 09, 2011 at 11:36 PM
 

Search in Used Dept. 



Rob Whiting
Offline
• •
Upload & Sell: Off
p.1 #8 · Used 5D MK II won't focus except in P mode


jzucker wrote:
I just cleared custom functions and it started working again in all modes with the 1/2 press. Shouldn't the factory settings reset clear that?



page 45 of the manual tells you what "clear all camera settings" clears.. The very last thing on that page: "custom functions - no changes"




Dec 09, 2011 at 11:44 PM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #9 · Used 5D MK II won't focus except in P mode


just did a test. Resetting to factory defaults does not clear custom functions!

What about the underexposure thing with the 580ex?



Dec 09, 2011 at 11:45 PM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #10 · Used 5D MK II won't focus except in P mode


sorry, I don't have a manual with it though the PDF would actually be better. Guess I need to download it from canon.

thanks.



Dec 09, 2011 at 11:48 PM
Rob Whiting
Offline
• •
Upload & Sell: Off
p.1 #11 · Used 5D MK II won't focus except in P mode


jzucker wrote:
just did a test. Resetting to factory defaults does not clear custom functions!

What about the underexposure thing with the 580ex?



Did you test before you cleared all camera settings & again after? You may have had FEC set. Clearing camera settings would reset that back to 0



Dec 09, 2011 at 11:49 PM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #12 · Used 5D MK II won't focus except in P mode


yes, I just tried the flash again and it now seems to be exposing properly.

Thanks folks. Sorry for the newb questions.



Dec 09, 2011 at 11:57 PM
mttran
Online
• • • • •
Upload & Sell: Off
p.1 #13 · Used 5D MK II won't focus except in P mode


Update your 5D2 with 2.1.1 F/W


Dec 10, 2011 at 01:30 AM
jzucker
Offline
• • • •
Upload & Sell: On
p.1 #14 · Used 5D MK II won't focus except in P mode


mttran wrote:
Update your 5D2 with 2.1.1 F/W


Thanks. Will do after the charger arrives.



Dec 10, 2011 at 01:47 AM





FM Forums | Canon Forum | Join Upload & Sell

    
 

You are not logged in. Login or Register

Username   Password    Retrive password