Home · Register · Search · View Winners · Software · Hosting · Software · Join Upload & Sell

Moderated by: Fred Miranda
Username   Password

  New fredmiranda.com Mobile Site
  New Feature: SMS Notification alert
  New Feature: Buy & Sell Watchlist
  

FM Forums | Canon Forum | Join Upload & Sell

1
       2       end
  

Archive 2011 · Canon 7D + 100-400 lens, focus issue...
  
 
2DeAnn
Offline

Upload & Sell: Off
p.1 #1 · p.1 #1 · Canon 7D + 100-400 lens, focus issue...


Since, I ran my firmware update, about a month ago on my canon 7D, I am having problems with the camera/lens (100-400) combo focusing. I have not had this issue, with any other lens, I've tried. Which leads me to think, possible lens issue.I have cleaned the lens contacts, and the camera contacts, in hope this would resolve the issue. Plus, I have reset the camera settings to factory default. Neither of these have worked. I never had any issues with this, prior to this firmware update. This could simply be a coincidence, as I couldn't find any known issues with this, via a google search for similar problems. I can have the camera/lens, setting on my lap (not touching any buttons) and can feel the lens trying to focus. It will eventually focus, with repeated attempts at hitting the shutter button.

I'd appreciate any and all suggestions/help with this. I'm planning on taking this in tomorrow to a local store, but would like to try to resolve on my own, if possible.

Thanks, ahead of time.
Terrie



Jun 28, 2011 at 09:46 PM
msalvetti
Offline
• • • •
Upload & Sell: On
p.1 #2 · p.1 #2 · Canon 7D + 100-400 lens, focus issue...


You could try a hard reset by taking out the battery and the internal button cell for about 20 minutes. I've read people say this improved the AF in their 7D's, but I'm not convinced the effect is real. Still worth a try.

Does this happen in all modes? One Shot, AI Servo, IS on or off? Have you tried changing the focus limiter switch on the lens to see if anything improves?

Sorry, can't be much help I'm afraid. Something like this I usually try a bunch of different combinations to see if I can find a situation where the lens behaves normally.

Mark



Jun 28, 2011 at 10:03 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #3 · p.1 #3 · Canon 7D + 100-400 lens, focus issue...


msalvetti wrote:
You could try a hard reset by taking out the battery and the internal button cell for about 20 minutes. I've read people say this improved the AF in their 7D's, but I'm not convinced the effect is real. Still worth a try.

Does this happen in all modes? One Shot, AI Servo, IS on or off? Have you tried changing the focus limiter switch on the lens to see if anything improves?

Sorry, can't be much help I'm afraid. Something like this I usually try a bunch of different combinations to see if I can find a situation where the lens
...Show more

Mark,
This is appearing in all the modes. One shot, AI Servo, and with IS on or off. I have also tried the focus limiter switch on the lens. I have tested in , AV and TV modes, also. From everything I have tried, I can't get it to behave normally.

I could try removing the internal button cell and see if it helps at all. It's one thing I haven't tried. Hopefully it isn't to hard to remove. Time for the manual

I appreciate your suggestions and time trying to help.
Terrie



Jun 28, 2011 at 10:07 PM
msalvetti
Offline
• • • •
Upload & Sell: On
p.1 #4 · p.1 #4 · Canon 7D + 100-400 lens, focus issue...


I can't think of much else. I would bring both the camera and the lens to the store, and try the lens on another body and if possible another 100-400 on the 7D.

But it sounds like the lens probably needs to go to Canon. If the lens works fine on a different 7D, I don't know what to tell you.

Unfortunately I'm pretty sure the current firmware updates are irreversible, so you won't be able to roll it back.

Mark



Jun 28, 2011 at 11:28 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #5 · p.1 #5 · Canon 7D + 100-400 lens, focus issue...


Thank you, Mark.

I tried the hard reset and just went out and retried the lens. No difference in the operation, of it. So I believe you are right. I will run this in tomorrow and see what the camera store has to say. Thanks for giving it a try!

Terrie



Jun 29, 2011 at 01:13 AM
howard
Offline
• • •
Upload & Sell: Off
p.1 #6 · p.1 #6 · Canon 7D + 100-400 lens, focus issue...


My friend, your use of comma, is, uh, very, innovative.


Jun 29, 2011 at 01:43 AM
Imagemaster
Offline
• • • • • • •
Upload & Sell: On
p.1 #7 · p.1 #7 · Canon 7D + 100-400 lens, focus issue...


howard wrote:
My friend, your use of comma, is, uh, very, innovative.


My, aren't we lucky to have a grammar teacher with us.



Jun 29, 2011 at 05:09 AM
pingflood
Offline
• • •
Upload & Sell: Off
p.1 #8 · p.1 #8 · Canon 7D + 100-400 lens, focus issue...


Imagemaster wrote:
My, aren't we lucky to have a grammar teacher with us.


You should check the guy's post history for all his valuable contributions.



Jun 29, 2011 at 07:39 AM
howard
Offline
• • •
Upload & Sell: Off
p.1 #9 · p.1 #9 · Canon 7D + 100-400 lens, focus issue...


Perhaps not as insightful as this comment of your?

pingflood wrote:
You should check the guy's post history for all his valuable contributions.




Jun 29, 2011 at 11:13 AM
PetKal
Offline
• • • • • • •
Upload & Sell: On
p.1 #10 · p.1 #10 · Canon 7D + 100-400 lens, focus issue...


howard wrote:
Perhaps not as insightful as this comment of your?



The correct grammar is "comment of yours".



Jun 29, 2011 at 11:43 AM
 

Search in Used Dept. 



2DeAnn
Offline

Upload & Sell: Off
p.1 #11 · p.1 #11 · Canon 7D + 100-400 lens, focus issue...


WoW...not sure what "incorrect grammar" has to do with my camera/lens, not functioning. I can safely say, that "incorrect grammar", has no effect on my camera or lens not working properly.

Sorry folks...but this was a totally uncalled for remark, from Howard.

Terrie



Jun 29, 2011 at 01:54 PM
AGeoJO
Offline
• • • • • •
Upload & Sell: On
p.1 #12 · p.1 #12 · Canon 7D + 100-400 lens, focus issue...


Terrie,
Did you do any micro-focus adjustment on your lenses prior to the firmware update? It is possible that the firmware update put that adjustment out of whack. How about re-doing the MF adjustment or if you had not done so in the first place, go through the process again? Just a suggestion.....



Jun 29, 2011 at 01:59 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #13 · p.1 #13 · Canon 7D + 100-400 lens, focus issue...


AGeoJO wrote:
Terrie,
Did you do any micro-focus adjustment on your lenses prior to the firmware update? It is possible that the firmware update put that adjustment out of whack. How about re-doing the MF adjustment or if you had not done so in the first place, go through the process again? Just a suggestion.....


AGeoJo,
No, I haven't ever done that with my camera. I will surely give that a try. I thank you for your suggestion. Just getting ready to take the camera in, to see what's up with it, but will give this a try first.

Terrie



Jun 29, 2011 at 02:05 PM
quicksilver33
Offline
• •
Upload & Sell: Off
p.1 #14 · p.1 #14 · Canon 7D + 100-400 lens, focus issue...


Breaking news - fixing comma usage will fix the AF in your 7D


Jun 29, 2011 at 02:37 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #15 · p.1 #15 · Canon 7D + 100-400 lens, focus issue...


quicksilver33 wrote:
Breaking news - fixing comma usage will fix the AF in your 7D


If only it were so easy



Jun 29, 2011 at 02:49 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #16 · p.1 #16 · Canon 7D + 100-400 lens, focus issue...


Well there was a definite issue, with the lens. It's been mailed off to canon, for repairs. The sad part is...it can take 6-8 weeks, before it's returned (so I was told), due to parts shortages.

Just want to say thanks again, to those who offered suggestions. It was all greatly appreciated.

Terrie



Jun 29, 2011 at 10:20 PM
msalvetti
Offline
• • • •
Upload & Sell: On
p.1 #17 · p.1 #17 · Canon 7D + 100-400 lens, focus issue...


That's too bad - I had forgotten about possible parts issues. I have an early version and I was thinking of sending it in for some cleaning and spiffing up in a few months - I don't use it much in the winter. Hopefully the parts issues will be sorted out by then.

Let us know when it comes back - hopefully good as new.

Mark



Jun 29, 2011 at 10:33 PM
2DeAnn
Offline

Upload & Sell: Off
p.1 #18 · p.1 #18 · Canon 7D + 100-400 lens, focus issue...


I don't use mine a lot, in the winters either. That's the bad thing, about the wait. Is loosing these summer months, with the lens. Then again...the lens isn't doing me any good, not working correctly. I am glad it was still under the warranty though. So that's a plus.

I will surely let you know, what the verdict was on the lens. I'm hoping it is also.

Terrie



Jun 30, 2011 at 01:02 AM
acs55812
Offline

Upload & Sell: On
p.1 #19 · p.1 #19 · Canon 7D + 100-400 lens, focus issue...


howard wrote:
My friend, your use of comma, is, uh, very, innovative.


I, can't, tell, did, that, add, anything, to, the, question, or, discussion,,,,,,,,,,,,,,,,,,,,,,,,,,,,,


itsalsohardtotypewhenmyspacebarisbroken



Jun 30, 2011 at 03:42 AM
af120835
Offline
• • •
Upload & Sell: Off
p.1 #20 · p.1 #20 · Canon 7D + 100-400 lens, focus issue...


Imagemaster wrote:
My, aren't we lucky to have a grammar teacher with us.


Actually it's punctuation not grammar. And it does make the post difficult to read.

Anyway I hope you get the focus problem sorted.



Jun 30, 2011 at 11:06 AM
1
       2       end




FM Forums | Canon Forum | Join Upload & Sell

1
       2       end
    
 

You are not logged in. Login or Register

Username   Password    Reset password